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About this Document
This document outlines the processes involved in performing various stamp collecting activities using
the Stamps application. It is assumed that users of this document will have Stamps already installed
on their computer system.
Stamps User Guide
By Paul Cook
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All rights reserved. Printed in Brisbane, Australia. This publication is protected by copyright, and
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The Seven Cookies name is a trademark of Seven Cookies.
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or programs contained herein.
Many of the designations used by manufacturers and sellers to distinguish their products are
claimed as trademarks. Where those designations appear in this book, and the publisher was aware
of a trademark claim, the designations have been printed with initial capital letters or in all capitals.

Audience
This document is intended for a general Mac user with some experience in stamp collecting and are
using Stamps on their Mac computer.

Typographical Conventions
To make this e-book easier to read, major user interface elements will be shown in a bold font.
Further information on a topic will be shown with an information symbol mark besides italic text,
and a light bulb besides italic text indicates a useful tip that you may wish to follow.
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Adding a Stamp
To add a stamp from your collection into the Stamps application, click on the Plus or Add button.

Figure 1 – Add Stamp Button.
After clicking on the Add button, you can add the stamp details in the table and form area of the
application (see figure 2). The table area contains the description, stamp face value, year, country of
issue and color, whereas the form contains catalog details, condition, faults, dimensions and
perforation count.
If you are adding stamps with similar data, use the Duplicate Stamp from the Edit menu to
duplicate (copy and paste) the selected stamp. The differences on the duplicate stamp to
your new stamp can be edited without needing to rekey similar data.
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Figure 2 – Adding a Stamp.
To add a scanned image of your stamp, drag the image file into the area shown in figure 2.
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Editing a Stamp
To edit details of a stamp, e.g. maybe the purchased cost of your stamp was entered incorrectly,
select the stamp and click on the field that requires changing (in figure 3 below, the purchased cost
has been selected).

Figure 3 – Editing Stamp Details.
The stamp details that can be edited in the table section are;
• Catalog ID; The identification number of the stamp from your catalog. This may also be used
to record any reference or invoice number associated with the purchase,
• Description; Description of the stamp, possibly from your stamp catalog,
• Face Value; The face value shown on the stamp (in figure 3, the face value is 1 pence or 1d),
• Year; Year of issue although you can enter more details if known, e.g. month and year, and
• Country; Country issuing the stamp.
In the form section, further details of the stamp can be recorded;
• Certificate; The certificate of authenticity number,
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Vendor; The name of the stamp dealer you purchased the stamp from,
Date Purchased; The date the stamp was purchased (defaults to today’s date),
Quantity Purchased; The quantity of stamps purchased (defaults to one),
Purchased Cost; The cost you paid for the stamp,
Catalog Value; The value of the stamp in your catalog or latest valuation for the stamp,
Used or Unused; Whether the stamp is used or unused, namely;
o Used,
o Unused, or
o Unused never hinged.
Gum Condition (Crandell, 2006); The condition of the gum of the stamp, namely;
o NH – Never Hinged (the gum is like new and no hinge marks of any kind),
o H – Hinged,
o LH – Lightly hinged (stamp has been hinged but mark is small or light),
o HH – Heavy hinged (large mark left or very prominent),
o HR – Hinge remnant (portion of hinge is still in place, difficult to remove),
o DG – Disturbed Gum (gum damaged in other ways, e.g. bubbling),
o NG – No Gum (Stamp is unused and has no gum),
o RG – Re-gummed (new gum has been applied to replace old gum),
o Gum skip (portion of stamp back has no gum applied), and
o MNH – Mint or Mint Never Hinged (new condition).
Centering (Crandell, 2006); How well is the design of the stamp centered within the edges,
namely;
o S – Superb (near perfect centering),
o XF – Extremely fine (almost perfect),
o VF – Very fine (design if off center but still well away from edges),
o F-VF – Fine to very fine (design is closer to edge, common for collected stamps),
o F – Fine (close to edge but not cut by perforations), and
o AVG – Average (design is cut by perforations).
Condition; A general score from 1 to 5 stars reflecting condition of stamp,
Faults (Crandell, 2006); The checkboxes of common faults on a stamp, namely;
o Short Perforations (perforation tips is not as long as it should be),
o Pulled Perforations (perforation tip is completely missing),
o Straight Edges (one or more edges do not have perforations),
o Re-perforated (alteration to stamp to add perforations),
o Thin (area on back where paper has been removed),
o Gum Bend / Wrinkle (stamp shrinkage resulting in a bend or wrinkle),
o Face Scrape (portion of front side of stamp has been scraped away),
o Inclusion (foreign material pressed into stamp), and
o Other provides a text field to enter other issues (e.g. tears, stains, creases, pinholes,
holes, corner missing, missing pieces etc.).
Dimensions; Width and height of the stamp,
Color; Color of the stamp, and
Perforations; Perforation count for top, left, right and bottom of the stamp.
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Images of the purchase invoice and certificate of authenticity can be stored against each stamp,
refer Stamp Documents section.
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Removing a Stamp
If you have sold a stamp, you may wish to remove it from the collection on your application. To
remove a stamp, click on the Minus or Remove button.

Figure 4 – Remove Stamp Button.
After clicking on the Remove button, a dialog box will appear asking you whether you wish to
remove the stamp (see figure 5). Click on Remove to remove the stamp from your collection,
otherwise, click on Cancel.
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Figure 5 – Removing a Stamp.
If you accidently remove a stamp, use the Undo feature (Edit > Undo menu) to restore the
stamp back into your collection.
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Filtering
To filter the list of stamps in the table or gallery (refer next section), click on the drop-down list to
select Catalog ID, Description, Face Value, Year and Country.

Figure 6 – Filter Selector.
After selecting the filter, typing part of a word in the Search field to filter the list and photo gallery
that contain those words. In figure 7, the numbers “1988” are entered to filter stamps that were
issued in the year.
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Figure 7 – Filtering Stamps by Year.
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Documents
To view your stamp’s documents, click on the Documents tab or select the Documents button from
the Touch Bar on supported MacBook Pros. The purchase invoice and certificate of authenticity can
be stored against each stamp by dragging an image onto either the invoice or certificate image area.

Figure 8 – Stamp Documents.
An image can be removed by clicking on it and pressing the Delete key.
An image can be magnified from 100% to 400% using the magnification slider (shown in red in the
figure above or zoom in and out by using pinch with two fingers if enabled for your trackpad), click
dragging to view an over-sized image or double-clicking on an image will open the image for viewing
in your external viewer (e.g. Preview).
The splitter can be moved up and down to show more of your invoice or certificate as desired.
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Gallery
To view your stamp collection images, click on the Gallery tab or select the Gallery button from the
Touch Bar on supported MacBook Pros. The gallery of images is filtered by the current search
criteria, refer previous Filtering section.

Figure 9 – Gallery of Stamps using Filter.
By selecting a photo in the Gallery, clicking on the Details tab will show details of the selected
stamp.
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Information
To view financial information on your stamp collection, select Get Info… from the File menu, click on
the blue information icon tab or select the Info button from the Touch Bar on supported MacBook
Pros. This information is filtered by the current search criteria, refer Filtering section.

Figure 10 – Stamp Information.
The following information is displayed on your collection;
• Number of Stamps; The sum of the quantities purchased for stamps within your collection,
• Total Portfolio Cost; The sum of the quantity purchased multiplied by purchased cost for
stamps within your collection,
• Total Portfolio Worth; The sum of the quantity purchased multiplied by catalog value for
stamps within your collection,
• Total Profit/(loss); The difference between your portfolio worth and cost.
The Report… button will print a portfolio report showing the cost, worth and profit for each of your
stamps.
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Reports
There are two reports available from the Reports menu, namely;
• Stamps Listing; This report prints the catalog ID, description, face value, year, country and
color for each stamp in your collection,
• Stamps Portfolio; This report prints the catalog ID, description, quantity, cost, worth and
profit (or loss) for each stamp in your collection. The quantities, cost, worth and profit are
totalled for all stamps, and
• Stamps Gallery; This report prints the stamp image with the details of the stamp appearing
as a list, namely, catalog ID, description, face value, year, country, color and dimensions.
The reports are filtered by your current search criteria, refer Filtering section.

Figure 11 – Reporting.
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Examples of the three reports (filtered on “Electricity” description) are shown below;

Figure 12 – Stamps Listing Reports.

Figure 13 – Stamps Portfolio Report.

Figure 14 – Stamps Gallery Report.
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CSV Import
It is possible to import your stamp collection from a spreadsheet so as to minimize rekeying of data
into Stamps. A sample CSV file is available from the Stamps support webpage for your review;
http://www.sevencookies.com.au/stamps.html.

Figure 15 – Example CSV File Headers.
The first row of your CSV file needs each column to have an appropriate header. The following
headers (or at least the first three unique characters shown in bold, case insensitive) should be used
to determine the type of data in each of the columns in your file;
• Catalog ID; The identification number of the stamp from your catalog,
• Description; description of the stamp, possibly from your stamp catalog,
• Denomination; the face value shown on the stamp,
• Year; year of issue although you can enter more details if known,
• Country; country issuing the stamp,
• Color; color of the stamp,
• Vendor; The stamp dealer you purchased the stamp from,
• Date Purchased; The date the stamp was purchased,
• Quantity; The quantity of stamps purchased,
• Cost; The purchased cost you paid for the stamp,
• Value; The current catalog value or valuation for the stamp,
• Used; Whether the stamp is used or unused,
• Gum; The condition of the gum (refer Editing a Stamp section),
• Centering; How well is the design of the stamp centered within the edges (refer Editing a
Stamp section),
• Condition; A general score from 1 to 5 (as a number) reflecting the condition of the stamp,
• Faults; The faults on the stamp with common checkbox faults enclosed in square brackets;
o [SP] for Short Perforations,
o [PP] for Pulled Perforations,
o [SE] for Straight Edges,
o [RP] for Re-perforated,
o [TH] for Thin,
o [GB] for Gum Bend / Wrinkle,
o [FS] for Face Scrape, and
o [IN] for Inclusion.
For example, a fault of “[SP][TH]Tearing” in the CSV file, would set the Short Perforation and
Thin checkboxes and set Other Faults to Tearing.
• Certificate; The certificate of authenticity number,
• Dimension; Width and height of the stamp,
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Top; Top perforation count,
Left; Left perforation count,
Right; Right perforation count, and
Bottom; Bottom perforation count.

After editing your CSV file to add or edit your header row using your spreadsheet application, export
the CSV with either the default UTF-8 text encoding (from Numbers) or ISO Latin-1 (from Excel).
A CSV is exported from Numbers using File > Export To… > CSV… menu option or using File > Save
As… menu option and selecting the Comma Separated Values (CSV) or CSV UTF-8 (Comma
delimited) from File Format drop-down from Excel.
To import the CSV file into Stamps, select the Import CSV… menu option from the File menu or dock
menu. After selecting your CSV file and clicking on Import or select the Import button from the
Touch Bar on supported MacBook Pros, the CSV file is read and analyzed and an alert with be shown
for major errors;
• Unable to open CSV file; The CSV has been saved using an unsupported encoding. Check
that your CSV was saved with UTF-8 or ISO Latin-1 encoding.
• CSV file is empty; The CSV does not contain any data. Please check the CSV file .
• CSV file contains invalid or no headers; There is either no CSV header row or none of the
headers used are valid. Review the CSV file to ensure if contains a header row and that those
headers are using the appropriate headers outlined previously.
• CSV file contains no stamp data; The CSV has valid headers but no data to import. Check the
CSV file has more than a header row.
If there are no major issues identified, an Import Preview window will be shown, see figure 16.
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Figure 16 – Import Preview.
The Import Preview window shows a table with the CSV data where you can scroll left and right or
up and down, resizing columns as required to preview the stamp data to be imported. An Issue Log
contains a list of issues found during the import process being either the header being unrecognized,
a duplicate or the format of some date or currency data being incorrect.
To resolve these issues, you may;
• For unrecognized headers, check the spelling of the header to the list outlined above,
• For duplicate headers, check the CSV file for headers with the same name and correct
appropriately,
• For incorrect data; check dates are in your locale’s format, either DD/MM/YYYY or
MM/DD/YYYY and numeric data may have currency symbols and decimal places added as
required but your locale’s thousand separator should not be used if it is a comma.
After reviewing the tabular data and the issue log, click Confirm to confirm the import or select the
Confirm button on the Touch Bar on supported MacBook Pros. A progress indicator will appear as
the stamps are imported into your collection.
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CSV Export
To export a CSV file to share your data with other collectors, use the File > Export As… menu option.
The CSV file will contain an initial row of headers followed by your stamp data with text separated in
quotes and each field separated by commas. The default UTF-8 text encoding will be used.

Figure 17 – Export CSV File.
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SQLite Housekeeping
Your stamp collection is stored in a SQLite database and periodically, requires some housekeeping
tasks to be performed, namely;
•

•

A vacuum which “rebuilds the database file, repacking it into a minimal amount of disk
space” (SQLite organisation, 2018). There are several reasons a periodic vacuum is required
o As you delete stamps from your collection it leaves behind empty space and the
database file size is larger than necessary which vacuuming can reduce, and
o Frequent additions, changes or deletions causes fragmentation of the data and
vacuuming stores data contiguously within the database file.
An analysis which “gathers statistics about tables and indices and stores the collected
information in internal tables of the database where the query optimizer can access the
information and use it to help make better query planning choices” (SQLite organisation,
2018).

When these tasks are performed during opening of your saved document, the wording “SQLIte
housekeeping done” appears in the status line.
Another factor which influences database size is that images are saved in a lossless format. To
reduce the size of your database, export your stamp images, certificate of authenticity and invoices
as Portable Document Format documents and drag and drop the PDFs instead of the original images.
The next SQLite vacuum will reclaim any unused space when you save the document.
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