Coins User Guide

Version: 1.10-12

Seven Cookies
Document History

<table>
<thead>
<tr>
<th>Date</th>
<th>Author</th>
<th>Description</th>
<th>Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>27/7/16</td>
<td>Paul Cook</td>
<td>Initial draft and screenshots for software versions 1.0 and 1.1</td>
<td>1.0</td>
</tr>
<tr>
<td>27/9/16</td>
<td>Paul Cook</td>
<td>New R1-9 ratings, listing report, portfolio information and report</td>
<td>1.2</td>
</tr>
<tr>
<td>29/10/16</td>
<td>Paul Cook</td>
<td>Added duplicate coin, NGC and PCGS grading scales, CSV import and export, database optimization and updated screenshots.</td>
<td>1.3</td>
</tr>
<tr>
<td>18/11/16</td>
<td>Paul Cook</td>
<td>Add CSV UTF-8 file format and thousand separator changes.</td>
<td>1.4</td>
</tr>
<tr>
<td>1/12/16</td>
<td>Paul Cook</td>
<td>Added purchased quantity</td>
<td>1.5</td>
</tr>
<tr>
<td>15/1/17</td>
<td>Paul Cook</td>
<td>Added invoice and certificate images and certificate number, simplified Details layout and added touch bar support.</td>
<td>1.6-7</td>
</tr>
<tr>
<td>3/10/17</td>
<td>Paul Cook</td>
<td>Accessible PDF; Added dock menu, preferences and screenshots</td>
<td>1.8-9</td>
</tr>
<tr>
<td>4/4/18</td>
<td>Paul Cook</td>
<td>Moved Catalog ID, added Gallery report and SQLite housekeeping.</td>
<td>1.10-12</td>
</tr>
</tbody>
</table>

About this Document

This document outlines the processes involved in performing various coin collecting activities using the Coins application. It is assumed that users of this document will have Coins already installed on their computer system.

Audience

This document is intended for a general Mac user with some experience in coin collecting and are using Coins on their Mac computer.

Typographical Conventions

To make this e-book easier to read, major user interface elements will be shown in a **bold** font. Further information on a topic will be shown with an information symbol mark besides *italic* text, and a light bulb besides *italic* text indicates a useful tip that you may wish to follow.
# Table of Contents

- Document History ........................................................................................................2
- About this Document .....................................................................................................2
- Coins User Guide ..........................................................................................................2
- Audience .......................................................................................................................2
- Typographical Conventions ..........................................................................................2
- Table of Contents .........................................................................................................3
- Adding a Coin .................................................................................................................4
- Editing a Coin ................................................................................................................5
- Removing a Coin ............................................................................................................7
- Filtering ..........................................................................................................................8
- Documents .....................................................................................................................9
- Gallery ...........................................................................................................................10
- Information ...................................................................................................................11
- Reporting .......................................................................................................................12
- CSV Import .....................................................................................................................14
- CSV Export ......................................................................................................................16
- Preferences ....................................................................................................................17
- SQLite Housekeeping .....................................................................................................19
- Reference List ...............................................................................................................20
Adding a Coin

To add a coin from your collection into the Coins application, click on the Plus or Add button.

After clicking on the Add button, you can add the coin details in the table and form area of the application (see figure 2). The table area contains the description, denomination, year, country of issue and category, whereas the form contains catalog and purchase details, grading, rarity, composition, diameter, weight, notes, obverse and reverse images.

If you are adding coins with similar data, use the Duplicate Coin from the Edit menu to duplicate (copy and paste) the selected coin. The differences on the duplicate coin to your new coin can be edited without needing to rekey similar data.
Editing a Coin

To edit details of a coin, select the coin and click on the field that requires changing (in figure 3 below, the Purchase Cost has been selected).

The coin details that can be edited in the table section are:

- **Catalog ID**: The identification number of the coin from your catalog. This may also be used to record any reference or invoice number associated with professional grading services,
- **Description**: description of the coin, possibly from your coin catalog,
- **Denomination**: the face value shown on the coin,
- **Year**: year of issue although you can enter more details if known,
- **Country**: country issuing the coin, and
- **Category**: select one of the categories (these can be added, changed or removed in Preferences).

In the form section, further details of the coin can be recorded:

- **Certificate No.**: The certificate of authenticity number,
- **Vendor**: The name of the coin dealer you purchased the coin from,
- **Date Purchased**: The date the coin was purchased (defaults to today's date),
- **Qty**: The quantity of coins purchased (defaults to one),
- **Purchased Cost**: The cost you paid for the coin,
- **Catalog Value**: The current catalog value or latest valuation for the coin,
- **Grading**: The default grading for your coin uses the Sheldon Coin Grading (Martinez, 2016), namely;
  - **Poor P(1)** – Extremely worn and barely identifiable,
  - **Fair FA(2)** – Almost smooth but some features are identifiable,
  - **About good AG(3)** – Readable letters although still worn,
  - **Good G(4-6)** – Worn but readable and rims are complete,
  - **Very good VG(8-10)** – Design worn but features are more prominent,
  - **Fine F(12-15)** – Lettering has deeper recesses in the detail,

*Figure 3 – Editing Coin Details.*
In **Preferences**, the default grading system can be changed to use either the NGC (NGC, 2016) or PCGS (PCGS, 2016) grading scales which are built upon the Sheldon Scale. Both of these scales’ numeric grades can be selected and edited. The selected numeric grade should be edited to;

- Change the strike type to;
  - remove either the MS or PF from MS/PF 60 to 70 scales for NGC grading,
  - remove either the MS or PR from MS/PR 60 to 70 scales for PCGS grading,
  - change lower graded coin’s strike type to PF or PR for proof coins, and
  - change strike type to SP for a hybrid coin between Mint State and Proof.

- Add Plus or Star designations;
  - add a star designation for NCS grading for coins with exceptional eye appeal for their assigned grade,
  - NCS plus grades for coins approaching the qualify requirements for the next grade are selectable for coins graded from XF 45 to MS 68 or PF 45 to PF 68,
  - add a plus grade for PCGS grading for any graded coin that exhibits exceptional eye appeal.

- Add Strike Characters or Designations;
  - add any strike characters or designations (CA for Cameo, DC for Deep Cameo etc.), NCS Release Designation or PCGS Designations, as applicable, to describe a particular coin attribute.

The following websites provide information on the numeric scales of NGC and PCGS;

- **NGC Grading Scale**: [https://www.ngccoin.com/coin-grading/grading-scale/](https://www.ngccoin.com/coin-grading/grading-scale/)

**Rarity**: The default rarity for your coin uses the Universal Rarity Scale (Martinez, 2016) that was developed by Quentin David Bowers, from **URS-1=Unique** to **URS-20=250,001+**.

In **Preferences**, the default rarity system can be changed to use the **R-1** to **R-9** scale (History Bank, 2010);

- **R-1** Common,
- **R-2** Uncommon,
- **R-3** Scarce,
- **R-4** Very Scarce,
- **R-5** Rare,
- **R-6** Very Rare,
- **R-7** Extremely Rare,
- **R-8** Nearly Unique, and
- **R-9** Unique.

**Composition**: The metal composition and variations therein of your coin,
**Diameter**: The diameter of your coin,
**Weight**: The weight of your coin,
**Notes**: Any notes you wish to add, e.g. shape, rim, obverse or reverse details. When entering notes, hold the OPTION key while pressing the RETURN key will create a line break.
Removing a Coin

If you have sold a coin, you may wish to remove it from the collection on your application. To remove a coin, click on the Minus or Remove button.

![Figure 4 – Remove Coin Button.]

After clicking on the Remove button, a dialog box will appear asking you whether you wish to remove the coin (see figure 5). Click on Remove to remove the coin from your collection, otherwise, click on Cancel.

![Figure 5 – Removing a Coin.]

If you accidently remove a coin, use the Undo feature (Edit > Undo menu) to restore the coin back into your collection.
Filtering

To filter the list of coins in the table or gallery (refer next section), click on the drop-down list to select Description, Denomination, Year, Country or Category.

![Figure 6 – Filter Selector.](image)

After selecting the filter, typing part of a word in the Search field to filter the list and photo gallery that contain those words. In figure 7, the word “Canberra” was entered to filter coins that were issued from the Canberra Mint (Royal Australian Mint).

![Figure 7 – Filtering Coins by Description.](image)
Documents

To view your stamp’s documents, click on the Documents tab or select the Documents button on the Touch Bar on supported MacBook Pros. The purchase invoice and certificate of authenticity can be stored against each coin by dragging an image onto either the invoice or certificate image area.

Figure 8 – Coin Documents.

An image can be removed by clicking on it and pressing the Delete key.

An image can be magnified from 100% to 400% using the magnification slider (shown in red in the figure above, or zoom in and out by using pinch with two fingers if enabled for your trackpad), click dragging to view an over-sized image or double-clicking on an image will open the image for viewing in your external viewer (e.g. Preview).

The splitter can be moved up and down to show more of your invoice or certificate as desired.
Gallery

To view all your coin images, click on the Gallery tab or select the Gallery button on the Touch Bar on supported MacBook Pros.

![Gallery of Coins using Filter.](image)

*Figure 9 – Gallery of Coins using Filter.*

By selecting a photo in the Gallery, clicking on the Details tab will show details of the selected coin.
Information

To view financial information on your coin collection, select Get Info... from the File menu, click on the blue information icon or select the Info button on the Touch Bar on supported MacBook Pros. This information is filtered by the current search criteria, refer Filtering section.

![Figure 10 – Coin Information.](image)

The following information is displayed on your collection:

- **Number of Coins**: The sum of the quantity purchased of coins within your collection,
- **Total Portfolio Cost**: The sum of the quantity purchased multiplied by purchased cost for coins within your collection,
- **Total Portfolio Worth**: The sum of the quantity purchased multiplied by catalog value for coins within your collection,
- **Total Profit/(loss)**: The difference between your portfolio worth and cost.

The Report... button will print a portfolio report showing the cost, worth and profit for each of your coins.
 Reporting

There are two reports available from the Reports menu, namely;

- **Coins Listing:** This report prints the catalog ID, description, denomination, year, country and category for each coin in your collection,
- **Coins Portfolio:** This report prints the catalog ID, description, quantity, cost, worth and profit (or loss) for each coin in your collection. The quantity, cost, worth and profit are totalled for all coins, and
- **Coins Gallery:** This report prints the stamp image with the details of the coin appearing as a list, namely, catalog ID, description, denomination, year, country, weight and diameter.

The reports are filtered by your current search criteria, refer **Filtering** section.

![Figure 11 – Reporting.](image)

Examples of the two reports are shown below;

![Figure 12 – Coins Listing Report.](image)
### Coins Portfolio Report

<table>
<thead>
<tr>
<th>Catalog ID</th>
<th>Coin Description</th>
<th>Qty</th>
<th>Total Cost</th>
<th>Total Worth</th>
<th>Total Profit</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCC:km62</td>
<td>Australian One Cent Coin Canberra Mint</td>
<td>1</td>
<td>$8.00</td>
<td>$8.00</td>
<td>$8.00</td>
</tr>
<tr>
<td>WCC:km64</td>
<td>Australian Five Cent Coin London Mint</td>
<td>1</td>
<td>$12.00</td>
<td>$12.00</td>
<td>$12.00</td>
</tr>
<tr>
<td>WCC:km65</td>
<td>Australian Ten Cent Coin London Mint</td>
<td>2</td>
<td>$28.00</td>
<td>$28.00</td>
<td>$28.00</td>
</tr>
<tr>
<td>WCC:km66</td>
<td>Australian Twenty Cent Coin London Mint</td>
<td>1</td>
<td>$35.00</td>
<td>$35.00</td>
<td>$35.00</td>
</tr>
<tr>
<td>WCC:km63</td>
<td>Australian Two Cent Coin Canberra Mint</td>
<td>1</td>
<td>$7.00</td>
<td>$7.00</td>
<td>$7.00</td>
</tr>
<tr>
<td></td>
<td>Total</td>
<td>6</td>
<td>$50.00</td>
<td>$50.00</td>
<td>$50.00</td>
</tr>
</tbody>
</table>

End of Report.

**Figure 13 – Coins Portfolio Report.**

### Coins Gallery Report

<table>
<thead>
<tr>
<th>Catalog ID</th>
<th>Coin Description</th>
<th>Face</th>
<th>Year</th>
<th>Country</th>
<th>Diameter</th>
<th>Weight</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCC:km62</td>
<td>Australian One Cent Coin Canberra Mint</td>
<td>1 cent</td>
<td>1966</td>
<td>Australia</td>
<td>17.65 millimetres</td>
<td>2.60 grams</td>
</tr>
<tr>
<td>WCC:km53</td>
<td>Australian Two Cent Coin Canberra Mint</td>
<td>2 cents</td>
<td>1966</td>
<td>Australia</td>
<td>21.59 millimetres</td>
<td>5.20 grams</td>
</tr>
<tr>
<td>WCC:km54</td>
<td>Australian Five Cent Coin London Mint</td>
<td>5 cents</td>
<td>1966</td>
<td>Australia</td>
<td>19.41 millimetres</td>
<td>2.83 grams</td>
</tr>
<tr>
<td>WCC:km55</td>
<td>Australian Ten Cent Coin London Mint</td>
<td>10 cents</td>
<td>1966</td>
<td>Australia</td>
<td>23.60 millimetres</td>
<td>5.66 grams</td>
</tr>
<tr>
<td>WCC:km56</td>
<td>Australian Twenty Cent Coin London Mint</td>
<td>20 cents</td>
<td>1966</td>
<td>Australia</td>
<td>28.65 millimetres</td>
<td>11.3 grams</td>
</tr>
</tbody>
</table>

End of Report.

**Figure 14 – Coins Gallery Report.**
CSV Import

It is possible to import your coin collection from a spreadsheet so as to minimize rekeying of data into Coins. A sample CSV file is available from the Coins support webpage for your review; http://www.sevencookies.com.au/coins.html.

The first row of your CSV file needs each column to have an appropriate header. The following headers (or at least the first four unique characters shown in bold, case insensitive) should be used to determine the type of data in each of the columns in your file;

- **Catalog ID**: The identification number of the coin from your catalog,
- **Description**: description of the coin, possibly from your coin catalog,
- **Denomination**: the face value shown on the coin,
- **Year**: year of issue although you can enter more details if known,
- **Country**: country issuing the coin,
- **Category**: a category for classifying your coins,
- **Vendor**: The name of the coin dealer you purchased the coin from,
- **Date Purchased**: The date the coin was purchased,
- **Quantity**: The quantity of coins purchased,
- **Cost**: The purchased cost you paid for the coin,
- **Value**: The current catalog value or valuation for the coin,
- **Grading**: A grading from Sheldon, NGC or PCGS grading scale,
- **Rarity**: A rarity from URS or the simplified R-1 to R-9 scale,
- **Composition**: The metal composition and variations therein of your coin,
- **Diameter**: The diameter of your coin,
- **Weight**: The weight of your coin,
- **Certificate**: The certificate of authenticity number, and
- **Notes**: Any miscellaneous notes relating to the coin.

After editing your CSV file to add or edit your header row using your spreadsheet application, export the CSV with either the default UTF-8 text encoding (from Numbers) or ISO Latin-1 (from Excel).

A CSV is export from Numbers using File > Export To... > CSV... menu option or using File > Save As...
menu option and selecting the **Comma Separated Values (CSV)** or **CSV UTF-8 (Comma delimited)** from **File Format** drop-down from Excel.

To import the CSV file into Coins, select the **Import CSV**... menu option from the **File** menu or dock menu. After selecting your CSV file and clicking on **Import** or select the **Import** button from the Touch Bar on supported MacBook Pros, the CSV file is read and an alert with be shown for errors;

- **Unable to open CSV file:** The CSV has been saved using an unsupported encoding. Check that your CSV was saved with UTF-8 or ISO Latin-1 encoding,
- **CSV file is empty:** The CSV does not contain any data. Please check the CSV file,
- **CSV file contains invalid or no headers:** There is either no CSV header row or none of the headers used are valid. Review the CSV file to ensure if contains a header row and that those headers are using the appropriate headers outlined previously, and
- **CSV file contains no coin data:** The CSV has valid headers but no data to import. Check the CSV file has more than a header row.

If there are no major issues identified, an **Import Preview** window will be shown, see figure below.

![Figure 16 – Import Preview.](image)

The **Import Preview** window shows a table with the CSV data where you can scroll left and right or up and down, resizing columns as required to preview the coin data to be imported. An **Issue Log** contains a list of issues found during the import process being either the header being unrecognized, a duplicate or the format of some date or currency data being incorrect.

To resolve these issues, you may;

- For **unrecognized headers**, check the spelling of the header to the list outlined above,
- For **duplicate headers**, check the CSV file for headers with the same name and correct appropriately, and
- For **incorrect data**; check dates are in your locale’s format, either DD/MM/YYYY or MM/DD/YYYY and numeric data may have currency symbols and decimal places added as required but your locale’s thousand separator should not be used if it is a comma.

After reviewing the tabular data and the issue log, click **Confirm** to confirm the import or select the **Confirm** button on the Touch Bar on supported MacBook Pros. A progress indicator will appear as the coins are imported into your collection.
CSV Export

To export a CSV file to share your data with other collectors, use the **File > Export As...** menu option. The CSV file will contain an initial row of headers followed by your coin data with text separated in quotes and each field separated by commas. The default UTF-8 text encoding will be used.

![Figure 17 – Export CSV File.](image-url)
Preferences

Coins preferences relate to how you wish to categorize your coin collection.

![Preferences](image)

*Figure 18 – Preferences.*

Use the **Add** or **Remove** (“+” and “-“) buttons to add into or remove entries from the category table, e.g. after clicking the **Add** button, an entry of “**New Category**” will appear that can be edited by clicking on it.

The **Hidden Columns** check boxes enable you to hide the denomination (if you are collecting coins of the same type or medals), year (if collecting coins from the same year or medals) or country (if collecting coins from the same country) in the table section.

The **Default Gradings** enables you to change the grading scale for your coin collection. The grading scales available are Sheldon (initial), NGC or PCGS. The NGC and PCGS grading scales enable you to select a numeric grade which can be edited to change strike type, add star designation and plus grades as well as other designations that describe your coins’ attributes.

The **Default Rarity** enables you to change the rarity scale for your coin collection. The rarity scales available are URS (initial) or a simplified R-1 to R-9 scale.

The **Enable edge image** checkbox is available for medal collectors that allows the addition of an optional edge photo (shown in red in figure overleaf). Drag and drop a medal edge photo to add or press Delete on an existing image to remove.

*The Coins app requires a restart for the edge image to be shown.*
Figure 19 – Enable rim image checkbox.

The Reset to Defaults button will reset the categories to their original settings.
SQLite Housekeeping

Your coin collection is stored in a SQLite database and periodically, requires some housekeeping tasks to be performed, namely;

- A vacuum which “rebuilds the database file, repacking it into a minimal amount of disk space” (SQLite organisation, 2018). There are several reasons a periodic vacuum is required
  - As you delete coins from your collection it leaves behind empty space and the database file size is larger than necessary which vacuuming can reduce, and
  - Frequent additions, changes or deletions causes fragmentation of the data and vacuuming stores data contiguously within the database file.
- An analysis which “gathers statistics about tables and indices and stores the collected information in internal tables of the database where the query optimizer can access the information and use it to help make better query planning choices” (SQLite organisation, 2018).

When these tasks are performed during opening of your saved document, the wording “SQLite housekeeping done” appears in the status line.

Another factor which influences database size is that images are saved in a lossless format. To reduce the size of your database, export your coin images, certificate of authenticity and invoices as Portable Document Format documents and drag and drop the PDFs instead of the original images. The next SQLite vacuum will reclaim any unused space when you save the document.
Reference List


