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About this Document 
This document outlines the processes involved in performing various genealogy research activities 
using the GedGap application. It is assumed that users of this document will have GedGap already 
installed on their computer system. 

GedGap User Guide 
By Paul Cook 
Copyright © 2015-2019 Seven Cookies. 

All rights reserved. Printed in Brisbane, Australia. This publication is protected by copyright, and 
permission must be obtained from the author prior to any prohibited reproduction, storage in a 
retrieval system, or transmission in any form or by any means, electronic, mechanical, photocopying, 
recording, or likewise. For information regarding permissions, contact Seven Cookies via 
https://sevencookies.com.au/. 

The Seven Cookies name is a trademark of Seven Cookies. 

The author has taken care in writing and printing this e-book but make no expressed or implied 
warranty of any kind and assume no responsibility for errors or omissions. No liability is assumed for 
incidental or consequential damages in connection with or arising out of the use of the information 
or programs contained herein. 

Many of the designations used by manufacturers and sellers to distinguish their products are 
claimed as trademarks. Where those designations appear in this book, and the publisher was aware 
of a trademark claim, the designations have been printed with initial capital letters or in all capitals.  

Audience 
This document is intended for a general Mac user with some experience in genealogy and are using 
GedGap in conjunction with their family tree research on a genealogy website or software.  

Typographical Conventions 
To make this e-book easier to read, major user interface elements will be shown in a bold font. 
For acronyms, the letters making up the acronym will be shown in an underline font. 
Further information on a topic will be shown with an information symbol mark besides italic text, 
and a light bulb besides italic text indicates a useful tip that you may wish to follow.  

https://sevencookies.com.au/
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Importing a GEDCOM 
When you start GedGap for the first time, the application’s status line asks you to open a file or 
import a GEDCOM file, refer figure 1. If you haven’t used GedGap before, a GEDCOM file should be 
imported to allow GedGap to analyse your family tree data to provide insights into research “Gaps”.  

 
A GEDCOM file is “an acronym standing for 
Genealogical Data Communication and is a 
de-facto standard for exchanging genealogy 
data” (Wikipedia, 2015) between different 
software or websites. Most genealogy 
websites will import and export your family 
tree as a GEDCOM file. 
 
 
 
 

For example, exporting your family tree from Ancestry can be completed by initially selecting Create 
& Manage Trees, refer figure 2, followed by Manage Tree, refer figure 3. 

 
 
 
 

 
 

 
After clicking on Manage tree, scroll page to the 
Manage your Tree and click on the Export tree button, 
refer figure 4. 
 
 
 

 
After clicking on Export tree, a message will appear to 
indicate that the GEDCOM file is being generated, refer 
figure 5. 
 

 
 

 
 
 
 
 
 

Figure 1 - Import GEDCOM message 

Figure 4 - Export tree 

Figure 2 - Create and manage trees 

Figure 3 - Manage tree 

Figure 5 - Generating a GEDCOM file 
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After the generation process is complete, a Download your 
GEDCOM file button will appear to allow you to download 
the GEDCOM file onto your computer, refer figure 6. 
 
 

 

 
To import this GEDCOM file into GedGap, 
select Import GEDCOM… from under the 
File menu or New from GEDCOM… from 
the dock menu and an import dialog will 
appear for you to select this file, refer 
figure 7. 
 
 
 
 
 
 
After selecting the file and clicking the Import button or select the Import button from the Touch 
Bar on supported MacBook Pros, GedGap will review the file (to ensure it is a valid GEDCOM file) and 
then import the data from the file. Depending on the size of the file, this process should take less 
than a minute. 
 
If the file is not a valid GEDCOM, an error message will appear outlining the issue, which typically is 
an unsupported GEDCOM encoding. GedGap supports most GEDCOM encodings and will import files 
from Microsoft and Apple operating systems, but if your file is not supported, please contact us for 
support (https://www.sevencookies.com.au/contact). 

  

Figure 6 - Download GEDCOM file 

Figure 7 - Import GEDCOM file 

https://www.sevencookies.com.au/contact
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GedGap Scoring and Flags 
At the end of the GEDCOM import process, GedGap will analyse the sources against each person’s 
birth and death event. The scoring determines the relevance of a source to the event with more 
relevant sources scoring higher, e.g. a birth certificate provides stronger evidence of the birth of a 
person than a census record. 
 

The scoring does not assume that a source includes the person’s name (although the 
examples used do include a name) so it is possible that a source is deemed to be relevant 
to the event but refer to a relative of that person, e.g. a birth certificate may refer to 
other siblings’ date of birth and be cited as a source in their birth event. 

 
The Audit tab provides details on how each source has been scored and the total of the birth and 
death GedGap scoring (referred to as Birth Gap and Death Gap respectively). 

 
In the figure 8, Isabella Louisa Taylor has a 
birth certificate source scoring 75 point, being 
more relevant to her birth than her death 
certificate which could have an approximate 
date of birth. 
 
Isabella has a total birth GedGap score (“Birth 
Gap”) of 150 points and a Death Gap score of 
80 points. The GedGap Score slider at the top 
of the screen, will filter people whose GedGap 
score is less than or equal to the slider value 
on the Plan, List and Audit tabs. 
 

If the slider value is set to 90, given that Isabella’s Death Gap score is 80, her details would be 
shown. GedGap uses the lower of the birth and death Gap score to determine whether the record is 
shown. Also, the Show Research Complete button is on to show people whose research is complete 
(see COMPLETED⚑ under ID). 
 
In addition, GedGap will show the overall average of all people in your family tree using the lower of 
a person’s birth or death Gap score using a color-coded indicator level shown in the top right of the 
window. 

 
When you start your research plan, it is recommended to set the slider value to less than 
this average score, to focus on people with less relevant sources. 
 

 
When a missing birth (or death) flag is not set for the person, a ⚐ white flag next to the Gap score 
total indicates vital sources have been identified (e.g. Birth Gap:⚐150 is shown in figure 8), 
whereas a ⚑ black flag indicates no vital sources found. Lastly, GedGap uses research flags to 
indicate the status of research to quickly identify “Gaps”.  

Figure 8 - Audit tab showing GedGap scoring 
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These research flags are; 
• Missing Birth; This flag indicates that a vital source, i.e. a source that provides strong 

evidence of the birth event is not cited against this person’s birth event, 
• Missing Death; Similar to the “Missing Birth” flag but this flag indicates the vital source is 

missing against the death event, 
• Research Exhausted; This flag indicates that research has ceased and is incomplete for this 

person, and 
• Research Complete; This flag indicates that research is complete. 

 
The People tab provides 
details on how each of 
these flags has been set 
and has a small help 
button on the lower right 
which if pressed, shows 
the legend for the various 
settings, refer figure 9. 
 
 
 
 
 
 
 
 
The People Legend shows the flag settings for; 

• Private (or Living) is an internal flag to identify living people or people marked private within 
the GEDCOM file, 

• Missing Birth labelled “Birth”, 
• Missing Death labelled “Death”, and 
• Research Exhausted and Complete under the last column labelled “Comp”. 

 
The GedGap Scoring and flag settings help identify people in your family tree who have less relevant 
sources for birth and death events or vital sources that are missing for these events. 
 
 
GedGap also supports embedded sources, i.e. citations that are not linked to a source record. The 
scoring of embedded sources is similar to source records, but the citation is also scored. This is 
because Ancestry allows embedded sources but given there is no source, the title is blank, and the 
citation detail contains the source reference. 
 
 
 
 

Figure 9 - People tab showing flag settings 
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To get an overview of all scoring for sources, 
the Sources table shows the relevancy of 
each source to the birth and death events. 
 
Mousing over the sources will show a tooltip 
containing additional information for the 
source, e.g. author, publisher, call number 
and repository etc. 
  

Figure 10 - Sources relevancy 
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Starting your Research Plan 
After setting the GedGap Score slider to less 
than the Average Score of 99 (the average 
score can be viewed by mousing over the 
green Average Score indicator to view the 
tool tip), so the slider value has been set to 
90, the Plan tab is shown in figure 11. 
 
 
 
 
 
 
 
The main features shown are; 

• Person’s name and an abbreviated birth and death date 
• The confidence rating which shows an initial GedGap analyse on how string are the birth and 

death sources in proving strong evidence for the birth and death events, 
• A priority (similar to a to-do list) where lower scored sources would have a higher priority, 
• A birth and death Tip which allows for a brief status or repository to search to be entered for 

each person’s birth and death research. 
 

Each of the table headers can be clicked to sort the table by that heading, e.g. it is useful 
to sort the table by priority to review people who have lower scored or fewer number of 
relevant sources or equally, to sort by confidence, with less vital sources having lessor 
proof in providing evidence of the birth or death event. 

 
By leaving the mouse pointer over a person, details on that person will appear in a tooltip. Double-
clicking on a person will enable the you to edit the confidence level, priority, birth and death tips in 
addition to adding some research notes or modifying the research flag settings, refer Editing your 
Research Plan section. 

  

Figure 11 - Plan tab showing research settings 
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Editing your Research Plan 
After double-clicking on a person in the Plan tab, a window is shown that allows you to edit the 
various research settings. 

 
In the figure 12, Isabella’s research includes 
notes based on a discussion with family 
members. The analysis settings include five 
star confidence, priority changed to Low, 
Death tip of “Review Burial” and Research 
Complete set to pending (a flag can be set off, 
on or mixed if that research is pending a 
review). 
 
 
 
 
 

The edit ruler can be turned on or off from the Format > Text > Show Ruler menu option and the 
edit research text font, size, style or color can be changed using the font panel (from the Format > 
Font > Show Fonts menu) or color panel (from the Format > Font > Show Colors menu). 
 
The confidence level can be editing by clicking on 1 to 5 stars depending on whether your review of 
the sources and your confidence that the sources cited provide weak or strong evidence of the birth 
and death of the person. 
 
Research notes allow you to enter the current status and next steps in your research plan for this 
person. Typically, they may refer to repositories that you wish to search or review, maybe libraries 
or cemeteries that you wish to visit in the area or people or relative to visit to discuss aspects of the 
research person’s life. 
 
The priority can be changed to any value that seems appropriate with people whose research is near 
complete having a lower value. GedGap uses the values of “0-Low” to “3-Low”, “4-Med” to “6-Med”, 
“7-High” to “9-High” in addition to the wording “Done” when research is complete, “Cease” if 
research is exhausted and “Living” for when a person is still alive and research maybe limited due to 
privacy reasons. You can use “Review” for when additional research activities are to be reviewed. 
 
The research tips contain brief status or repositories to be searched. 
 
The research flags can be set or cleared based on your review of the research status.  Some research 
flags allow a pending setting when research review is underway, e.g. if you are currently reviewing 
birth information, you may wish to set the “Missing Birth” flag to pending which would show as a 
question mark on the research plan reports or the People tab window. 
 

Figure 12 - Editing individual research 
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If your research is not identifying any additional information on a person’s birth or death, setting the 
“Research Exhausted” flag marks that research for this person has ceased and is incomplete. 
 
GedGap will validate the various research flags settings, e.g. had the “Research Complete” flag been 
set, if you set the “Missing Birth” flag to indicate that vital sources on the person’s birth are still to 
be cited, this would clear the “Research Complete” flag setting. 
 
Clicking once on the “Missing Birth”, “Missing Death” or “Research Complete” flags sets them to 
pending (shown as a dash in the checkbox) whereas clicking them again will show a tick in the 
checkbox.  
 

Setting a person’s research as exhausted or complete, can hide this person’s research 
information on the Plan tab (refer Preferences section). This allows you to concentrate 
on research that is currently underway or still to commence.  

 
Lastly, the Tree tab allows you to enter research notes on the family tree as a whole, e.g. you may 
wish to record a brief to-do type list or maybe identify current people being researched. 
 

BDM Registries are typically Pay-per-View but other online repositories have set fees to 
allow access to all (or partial) records per month but they do allow free (but limited) 
searching. Use the research notes to record these searches as your time permits, and 
when you have sufficient quantity, pay for a month’s access to verify the record details. 
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Viewing Family Tree Details 
To view details of people in your family tree, click of the List tab (or select the List button on the 
Touch Bar on supported MacBook Pros) will show research details of people whose research GedGap 
score is less or equal to the slider value. The detail shown are the research flag settings, GedGap 
scores and the sources for the birth and death events and research confidence, priority and notes 
etc. 
 
By entering a name or ID in the search field, 
the List tab will be updated to show details 
for that person. Conversely, clicking on a 
person in the Plan tab, will also set this search 
field to that person’s ID. This is useful when 
preparing the research plan for each person, 
as the List and Audit tabs are updated to 
show that person’s details. Clicking the small 
ⓧ button at the end of the search field will 
clear this value. 
 
 
 
 
 
When the search field is cleared, the List tab allows further filtering of information using the 
checkboxes, namely; 

• Show Missing Birth; normally set on to show people whose “Missing Birth” research flag is 
set. By clearing this checkbox, the List tab would show people whose GedGap score is less 
than or equal to the slider value and who do not have a missing birth flag set, 

• Show Missing Death; same as Missing Birth but for the “Missing Death” research flag, 
• Show Private or Living; normally set off to hide people who as still living, and 
• Show Research Complete; normally set off to hide people whose “Research Complete” flag 

has been set. 
 

These checkboxes enable you to view all people under (or equal to) the GedGap slider value and 
depending on the checkboxes set, filter this list further to allow your review of their sources and 
research information. The Audit tab has similar features as the List tab, refer figure 8. 
 
Please refine your search details since the List and Audit output is limited to details for 500 
individuals. 
 
The Sources tab shows the list of sources and repositories of those sources in a table. 
 
Lastly, printing the List tab (via the File and Print… or selecting Report and List… menu option) will 
print this listing to a printer or can be saved to a portable document format (PDF) file if desired (see 
next section). 
 

  

Figure 13 - List details for selected person from Plan tab 
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Printing Reports 
To print reports from the various tab views, you can choose Print from the File menu or select the 
report from the Reports menu. 
 
The reports available are; 

• Plan; This report shows the same details as the Plan tab in a tabular form, showing the name 
and birth-death date, confidence, priority and birth and death tips. Its purpose is to show 
the research plan for each person, 

• List; This allows the List tab details to be printed (including the research notes) based on the 
search field or the various checkboxes and GedGap score slider value, 

• Audit; This allows the Audit tab details to be printed (similar to above), 
• Sources; This allow the source details to be printed, i.e. a listing of each source and its 

respective repository, and 
• Tree; This allows your research tree notes to be printed. 

 
To prevent clipping of some data from report columns, change the print 
orientation to landscape or reduce the print scaling factor (under File > Print 
Setup… menu). 
 

Examples of reports from our unedited sample GEDCOM file (from our website) are shown below; 

 

Figure 14 - Reporting 

Figure 15 - Plan Research report 
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Figure 16 - List report 

Figure 17 - Audit Listing report 

Figure 18 - People Listing report (excluding legend, which is printed at end of report) 



GedGap User Guide 

  15 

 

 

 

  

Figure 19 - Sources Listing report extract (portrait orientation) 

Figure 20 - Source Listing report extract (landscape orientation showing repository) 

Figure 21 - Tree report (showing initial default text) 
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Re-import GEDCOM 
After conducting your research and updating your family tree from a website or other 
genealogy software, you may wish to review the impact of these changes by re-importing a 
newly exported GEDCOM file back into GedGap. 
 
GedGap will re-calculate the birth and death scores, priority and confidence for additional 
sources added to your family tree. Any prior research notes or changed birth and death tips 
will remain untouched. 
 

GedGap uses the individual ID to match individuals from the newly created 
GEDCOM file to the original people. This allows you to change the name of people 
within your family tree research (spelling errors or addition of middle names). 
Some genealogy software re-used deleted individual IDs, so if you delete a person 
and add another, the same ID will be used for both (name change issue). 

 
Select the File > Re-import GEDCOM… 
menu option and select the newly 
exported GEDCOM file and click on the 
Reimport Button or select the 
Reimport button from the Touch Bar 
on supported MacBook Pros, refer 
figure 22. 
 
 
 

 

The GEDCOM file is analyzed and the 
changes can be reviewed and confirmed, 
refer figure 23, showing changes made from 
our sample website GEDCOM file. 
 
 
 
 
 
 
 
 
 
 
The indicators in the GEDCOM changes for table are colored; 

• Red; due to removing a source or decreasing the score of a birth or death source 
type, 

• Yellow; minimal or no change, and 
• Green; due to adding a source or increasing the score of a birth or death source type. 

Figure 22 - Re-import 

Figure 23 - Confirm re-import changes 
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The change log shows the following; 
• A change of name which could be due to a spelling error correction or change in 

name, and 
• Individuals added or removed are shown. 

 
To proceed with the changes, click on the Confirm button or select the Confirm button from 
the Touch Bar on supported MacBook Pro. 
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Preferences 
GedGap preferences relate to your GEDCOM file having customized tags which usually would come 
from your genealogy software rather than a website. The purpose of including custom tags is to 
verify those settings in your family tree to the internal logic within GedGap when the GEDCOM file is 
imported and identify any possible mismatches. 
 
In addition, GedGap has preferences for privacy to identify when birth or death research maybe 
limited. For example, from the New South Wales family history website allows unrestricted 
searching for births over 100 years ago and deaths over 30 years (Registry of Birth, Deaths and 
Marriages, Justice Department of NSW, 2015). 

Select the GedGap > Preferences… menu option or Preferences… from the dock menu to show the 
preferences window, which allows you to set the GEDCOM tag for missing birth and death, research 
complete and exhausted, the private flag setting and research notes (if you are unsure about 
GEDCOM tags or your GEDCOM file is sourced from a website, you can leave the default settings). 
 
Secondly, you can set the privacy for birth and death records to indicate when research maybe 
limited due to access restrictions for privacy reasons. 
 
Thirdly, the birth and death scoring can be modified with various source types and their respective 
scores. For example, source titles with the wording “Baptism” (case insensitive) would score 50 
points to reflect the strength of evidence a baptism record is for the birth event. The scoring is 
between 1 and 100, with scores 50 and above being classified as vital sources. The missing birth and 
death flags are set for when there are no vital sources for the birth and death events respectively 
when importing a GEDCOM file. For example, a birth certificate should be scored 50 points or above 
since it is a vital source since it provides string evidence to prove the birth event. 
 
Use the Add or Remove (plus or minus) buttons to add into or remove entries from each table, e.g. 
after clicking the Add button for birth sources, an entry of “New Birth Source” with a score of 10 will 
appear that can be edited by clicking on it. 
 
Setting the Hide Living, Privacy and Research Exhausted and Complete in Plan table button to on 
will hide all individuals who are either living or private or have their research exhausted or complete 
flag set from the Edit Plan window (see figure 11). Individuals to whom birth and death privacy 

Figure 24 - Preferences 
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filters apply would also be hidden. This allows you to concentrate on research that is currently 
underway or still to commence. 
 
The Revert to Defaults button will reset all Preferences values to their default settings. 
 
After clicking the Done button, use the Edit > Recalculate GedGap Scores menu option to calculate 
new birth and death scores for each person in your file or you can re-import your GEDCOM file. The 
latter approach uses these new scores to set confidence, priority, birth and death research tips and 
flag settings.  
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